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Conventions Used in this Guide

Please take a moment to review how instructions and other useful information are presented in
this documentation.

l Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.

l Bold type is used for the following:
o Keyboard entries that should be typed in their entirety exactly as shown. For
example, “copy file1” means you must type the word copy, then type a space, and
then type file1.

o On-screen prompts and messages, names of options and text boxes, and menu
commands. Menu commands are often separated by greater than signs (>). For
example, “click HFSS > Excitations > Assign >Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to
press the key labeled Enter.

l Italic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in
italics. For example, “copy filename” means you must type the word copy, then
type a space, and then type the name of the file.

l The plus sign (+) is used between keyboard keys to indicate that you should press the
keys at the same time. For example, “Press Shift+F1” means to press the Shift key and,
while holding it down, press the F1 key also. You should always depress the modifier key
or keys first (for example, Shift, Ctrl, Alt, or Ctrl+Shift), continue to hold it/them down, and
then press the last key in the instruction.

Accessing Commands: Ribbons, menu bars, and shortcut menus are three methods that can
be used to see what commands are available in the application.

l The Ribbon occupies the rectangular area at the top of the application window and con-
tains multiple tabs. Each tab has relevant commands that are organized, grouped, and
labeled. An example of a typical user interaction is as follows:

"Click Draw > Line"

This instruction means that you should click the Line command on the Draw ribbon tab.
An image of the command icon, or a partial view of the ribbon, is often included with the
instruction.

l Themenu bar (located above the ribbon) is a group of the main commands of an applic-
ation arranged by category such File, Edit, View, Project, etc. An example of a typical user
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interaction is as follows:

"On the Filemenu, click theOpen Examples command" means you can click the File
menu and then clickOpen Examples to launch the dialog box.

l Another alternative is to use the shortcut menu that appears when you click the right-
mouse button. An example of a typical user interaction is as follows:

“Right-click and select Assign Excitation> Wave Port” means when you click the right-
mouse button with an object face selected, you can execute the excitation commands
from the shortcut menu (and the corresponding sub-menus).

Getting Help: Ansys Technical Support

For information about Ansys Technical Support, go to the Ansys corporate Support website,
http://www.ansys.com/Support. You can also contact your Ansys account manager in order to
obtain this information.

All Ansys software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were
taken or what stages the simulation reached, including software files as applicable. This allows
more rapid and effective debugging.

Help Menu

To access help from the Help menu, click Help and select from the menu:

l [product name] Help - opens the contents of the help. This help includes the help for the
product and itsGetting Started Guides.

l [product name] Scripting Help - opens the contents of the Scripting Guide.
l [product name] Getting Started Guides - opens a topic that contains links to Getting
Started Guides in the help system.

Context-Sensitive Help

To access help from the user interface, press F1. The help specific to the active product (design
type) opens.

You can press F1 while the cursor is pointing at a menu command or while a particular dialog
box or dialog box tab is open. In this case, the help page associated with the command or open
dialog box is displayed automatically.
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1 - Introduction
This document is intended as supplementary material to Icepak for beginners and advanced
users. It how to model a finned heat sink using Ansys Icepak as well as many features and func-
tions essential to any Ansys Icepak project. For the sake of brevity, many of the later tutorials do
not cover basic steps or explain the steps in detail as those tutorials assume you have completed
this tutorial beforehand.

In this tutorial you will learn how to:

l Create a new project
l Create a model using geometry and thermal boundary conditions
l Generate a mesh for your model
l Set up a simulation with various physical conditions and parameters, including turbulence
l Calculate a solution
l Post-process your results by plotting field overlays of contours and vectors on plane cuts
and object geometry

This chapter contains the following topic:

l "Sample Project - The Finned Heat Sink" below

Sample Project - The Finned Heat Sink
The cabinet contains an array of five high-power devices, a backing plate, ten fins, three fans,
and a free opening, as shown in the figure below. The fins and backing plate are constructed of
extruded aluminum. Each fan has a total volume flow rate of 18 cfm and each source dissipates
power at the rate of 33 W. According to the design objective, the base of the devices should not
exceed 65°C when air sweeps the fins at an ambient temperature of 20°C.

Getting Started with Icepak®: Finned Heat Sink
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Figure 1-1: Finned Heat Sink
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2 - Create a Project and Build the Model
After launching the Ansys Electronics Desktop, create a project, insert an Icepak design, and
build the model.

Set 3D UI Options
Ensure that the new view orientation scheme introduced in release 2024 R1 is not being used,
since the instructions and images in this guide are based on the legacy orientation scheme.

1. From the menu bar, click View >Options.

The 3D UI Options dialog box appears.

2. Ensure that Enable Legacy View Orientation is enabled:

3. ClickOK.

Getting Started with Icepak®: Finned Heat Sink
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Create a Project
1. On the Desktop ribbon, click New.
2. From the Projectmenu, select Insert Icepak Design.
3. In the Project Manager, right-click on the project name and select Rename.
4. Rename the project "Finned_Heat_Sink."
5. From the Filemenu, select Save.
6. Save the project in your working directory.

Build the Model
Resize the Cabinet
1. In the History tree, expandModel > Solids > air > Region and select CreateRegion.
2. In the Properties window, define the following parameters:

l +X Padding Type: Absolute Position
l +X Padding Data: 0.075 meter
l -X Padding Type: Absolute Position
l -X Padding Data: 0 meter
l +Y Padding Type: Absolute Position
l +Y Padding Data: 0.25 meter
l -Y Padding Type: Absolute Position
l -Y Padding Data: 0 meter
l +Z Padding Type: Absolute Position
l +Z Padding Data:0.356 meter
l -Z Padding Type: Absolute Position
l -Z Padding Data: 0 meter

Create the Backing Plate
The backing plate is 0.006 m thick and divides the cabinet into two regions: the device side
(where the high-power devices are contained in a housing) and the fin side (where the fins dis-
sipate heat generated by the devices). The backing plate is represented in the model by a solid
prism block.

Note: Blocks and conducting thick plates allow six-sided control for meshing and
thermal specifications. Conducting thin plates, however, have no physical thickness
and therefore allow for only two-sided control.

Create a Project and Build the Model 2-2
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1. From the Drawmenu, select Box.
2. Press F4 to enter dialog entry mode.

Note: You can toggle between drawing methods by pressing F3 (point mode) or
F4 (dialog entry mode).

3. In the CreateBox dialog box Command tab, define the following size parameters and
units:

l Position: 0, 0, 0 meter
l XSize: 0.006 meter
l YSize: 0.25 meter
l ZSize: 0.356 meter

4. On the Attribute tab, enter backing_plate for the Name.
5. ClickOK.

Create the Free Opening
1. Press F to enter face selection mode.
2. In the 3D Modeler window, select the top face of the Region (cabinet).

3. Right-click and select Assign Thermal > Opening > Free.
4. In theOpening Thermal Model dialog box, enter FreeOpening as the Name.
5. Click OK to accept the default thermal and flow specifications.

Create a Project and Build the Model 2-3
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Create the Fans
Each fan is physically identical to the others, except with respect to its location on the cabinet
wall. To create the set of three fans, you will build a single fan as a template and then create two
copies, each with a specified offset in the Y direction.

1. In the Project Manager, right-click on 3D Components and select Create > Fan.
2. In the Fan Component dialog boxGeometry tab, define the following parameters:

l Radius: 0.03 meter
l Hub Radius: 0.01 meter

3. On the Properties tab, define the following parameters:
l Flow Type: Fixed Volumetric - 18 cfm

4. ClickOK.
5. In the History tree, expand Fan1.
6. Right-click Fan1_1 and select Edit > Arrange > Move.
7. In theMove dialog box, enter 0.04, 0.0475, 0 for theMove Vector Value.
8. Change the Unit tometer.
9. Click OK.
10. In the History tree, right-click Fan1_1 and select Edit > Duplicate > Along Line.
11. In the DuplicateAlongLine dialog box, enter 3 for the Total Number.
12. Enter 0 ,0.0775 ,0 for the Vector.
13. Change the Unit tometer.
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14. Click OK.

Create the High Power Devices
Like the fans, each device is physically identical to the others, except with respect to its location.
To create the set of five devices, you will build a single rectangular planar source as a template
and then create four copies, each with a specified offset in the Y direction.

1. From the Drawmenu, select Rectangle.
2. In the CreateRectangle window Command tab, define the following size parameters and

units:
l Position: 0, 0.0315, 0.1805 meter
l Axis: X
l XSize: 0.007 meter
l ZSize: 0.02 meter

3. On the Attribute tab, enter HighPowerDevice1 as the Name.
4. In the History tree, right-click HighPowerDevice1 and select Assign Thermal > Source.
5. In the Source Thermal Model dialog box, enter 33 W for the Total Power.
6. Click OK.
7. In the History tree, right-click HighPowerDevice1 and select Edit > Duplicate > Along

Line.
8. In the DuplicateAlongLine dialog box, enter 5 for Total Number.
9. Enter 0, 0.045, 0 for the Vector.
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10. Change the Unit tometer.
11. Click OK.

Create the Fins
Like the fans and devices, each fin is physically identical to the others, except with respect to its
location in the cabinet. To create the array of ten fins, create a rectangular plate as a template.
Then create nine copies, each with a specified offset in the Y direction.

1. From the Drawmenu, select Box.
2. In the CreateBox dialog box, define the following size parameters and units:

l Position: 0.006 ,0.0125 ,0.05 meter
l XSize: 0.069 meter
l YSize: 0.0025 meter
l ZSize: 0.281 meter

3. ClickOK.
4. In the History tree, right-click Box1 and select Edit > Duplicate > Along Line.
5. In the DuplicateAlongLine dialog box, enter 10 for Total Number.
6. Enter 0, 0.025, 0 for the Vector.
7. Change the Unit tometer.
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8. Click OK.

Review Model Components
The Design List displays information about the model components.

1. From the Icepakmenu, select List.
2. Review the component information in the Design List dialog box.

Note: Select one or more components in the Design List to select them in the His-
tory tree and 3D Modeler window.

3. From the Filemenu, select Save.

Create a Project and Build the Model 2-7
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3 - Generate and Display Mesh
After building the model, generate and display the mesh.

Generate a Coarse Mesh
1. In the Project Manager, right-clickMesh and select Edit Global Region.
2. On the Advanced tab, disable the User specified check box.
3. On theGeneral tab under Auto Mesh Setting, ensure the slider bar is in the middle

between Coarse/Small and Fine/Large position.

4. ClickOK.
5. In the Project Manager, right-clickMesh and selectGenerate Mesh.

Display the Coarse Mesh
TheMesh Visualization dialog box automatically appears after the meshing process com-
pletes.

1. In theMesh Visualization dialog box underMesh display on, enable Show and select
Geometry/Boundary selection.

2. In the History tree, right-clickModel and select Select All.

Getting Started with Icepak®: Finned Heat Sink
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3. Click Close.

Generate a Fine Mesh
1. In the Project Manager, right-clickMesh and select Edit Global Region.
2. On theGeneral tab under Auto Mesh Setting, move the slider bar to the Fine/Large pos-

ition.
3. ClickOK.
4. In the Project Manager, right-clickMesh and selectGenerate Mesh.

Display the Fine Mesh
TheMesh Visualization dialog box automatically appears after the meshing process com-
pletes.

1. In theMesh Visualization dialog box underMesh display on, enable Show and select
Geometry/Boundary selection.

2. In the History tree, right-clickModel and select Select All.
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3. Click Close.
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4 - Define the Simulation Settings and
Run the Analysis

Define the Design Settings
1. From the Icepakmenu, select Design Settings.
2. On the Icepak Design Settings dialog boxGravity tab, selectGlobal::Y and Negative to

define the force of gravity in the negative Y direction based on the Global coordinate sys-
tem.

3. ClickOK.

Add a Solution Setup
1. In the Project Manager, right-click Analysis and select Add Solution Setup.
2. On the Icepak Solve Setup dialog boxGeneral tab, change theMaximum Number of

Iterations to 200.
3. Under Problem Types, retain the selections to solve for both Temperature and Flow.
4. Under Flow Regime, select Turbulent and clickOptions. In the Turbulent Flow Model

dialog box, retain the Zero Equation selection and clickOK.
5. Under Radiation Model, retain theOff selection to ignore heat transfer due to radiation.
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6. ClickOK
7. From the Filemenu, click Save.

Run the Simulation
1. In the Project Manager, expand Analysis.
2. Right-click Setup1 and select Analyze.
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3. Right-click Setup1 and select Residuals to monitor the simulation residuals.

Note:When the simulation is complete, a message is displayed in theMessages win-
dow stating "Normal completion of simulation on server."

Add a Solution Setup and Run the Simulation 4-3

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 4-4

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with Icepak®: Finned Heat Sink



5 - Post-process the Results
The Ansys Electronics Desktop provides a number of ways to view and examine the solution res-
ults, including:

l Plane cut views
l Object face views
l Fields summary report

Note: The objective of this exercise is to determine whether the air flow and heat trans-
fer associated with the heat sink (fans and fins) are sufficient to maintain device tem-
peratures below 65°C. You can accomplish this by creating different plane cuts and
monitoring the velocity vector and temperature on it. Plane-cut views allow you to
observe the variation in a solution variable across the surface of a plane.

Create Plane Cut Field Overlays
Create a Plane
1. From the Drawmenu, select Plane.
2. In the 3D Modeler window, click twice to draw a plane.
3. In the History tree, expand Planes and select Plane1.
4. In the Properties window, edit the following properties:

l Name: cut-plane
l Root point: 0.0375 ,0.125 ,0.178 meter
l Normal: 1 ,0 ,0 meter

Plot Speed
1. In the History tree, select cut-plane.
2. Right-click in the 3D Modeler window and select Plot Fields > Velocity > Velocity Vect-

ors.
3. In the Create Field Plot dialog box, enable Specify Name and enter cut-velocity.
4. Retain the Velocity Vectors selection forQuantity and clickOK.
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5. In the Project Manager, expand Field Overlays > Velocity.
6. Right-click cut-velocity and select Plot Visibility to hide the field plot.

Plot Temperature
1. In the History tree, select cut-plane.
2. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-

perature.
3. In the Create Field Plot dialog box, enable Specify Name and enter cut-temperature.
4. Retain the Temperature selection forQuantity and clickOK.
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5. In the Project Manager, expand Field Overlays > Velocity.
6. Right-click cut-velocity and select Plot Visibility to hide the field plot.

Plot Pressure
1. In the History tree, select cut-plane.
2. Right-click in the 3D Modeler window and select Plot Fields > Pressure > Pressure.
3. In the Create Field Plot dialog box, enable Specify Name and enter cut-pressure.
4. Retain the Pressure selection forQuantity and clickOK.
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5. In the Project Manager, expand Field Overlays > Pressure.
6. Right-click cut-pressure and select Plot Visibility to hide the field plot.

Create Object Field Overlays
Plot Temperature on High Power Devices
1. In the History tree, expand Sources and select all five high power devices.
2. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-

perature.
3. In the Create Field Plot dialog box, enable Specify Name and enter highpowerdevice-

temperature.
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4. Retain the Temperature selection forQuantity and clickOK.

Plot Temperature on the Backing Plate
1. In the History tree, expand Al-Extruded and select backing_plate.
2. Right-click in the 3D Modeler window and select Plot Fields > Temperature > Tem-

perature.
3. In the Create Field Plot dialog box, enable Specify Name and enter backingplate-tem-

perature.
4. Retain the Temperature selection forQuantity.
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5. Enable Plot on surface only and clickOK.

Create a Fields Summary Report
Create a fields summary report of object-specific solution data. Fields summary reports can
provide physical information from the solution about specific model boundary conditions or
objects.

1. From the Icepakmenu, select Fields > Create Fields Summary.
2. In the Setup Calculation dialog box, selectObject for Entity Type.
3. In the Entity list, select backing_plate.
4. In theQuantity list, select HeatFlowRate.
5. From the Add drop-down list, select Add As Single Calculation.
6. Repeat steps 3 through 5 for the following entities and quantities.

Note: You can select multiple entities at once. When an entity is selected, select it
again to clear the selection.
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Entity Quantity
Fan1_Hub, Fan1_Hub2, Fan1_Hub3, Fan1_
Passage, Fan1_Passage2, Fan1_Passage3 VolumeFlowRate

HighPowerDevice1, HighPowerDevice1_
1, HighPowerDevice1_2, HighPower-
Device1_3, HighPowerDevice1_4

HeatFlowRate

Fin1, Fin1_1, Fin1_2, Fin1_3, Fin1_4,
Fin1_5, Fin1_6, Fin1_7, Fin1_8, Fin1_9 HeatFlowRate

Post-process the Results 5-7

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.



PDF layout 5-8

Ansys Electromagnetics Suite 2025 R2 - © ANSYS, Inc. All rights reserved. - Contains proprietary and confidential

information of ANSYS, Inc. and its subsidiaries and affiliates.

Getting Started with Icepak®: Finned Heat Sink



6 - Summary
In this tutorial, you have determined the ability of the specified heat sink to maintain source tem-
peratures below 65°C. Post-processing results show that the maximum source temperature is
about 60°C, indicating that the heat sink provides adequate cooling for the sources. In addition,
you have learned the basic workflow of an Icepak project, including model building, mesh gen-
eration, problem setup, solution calculation, and post-processing as well essential features and
functions that you will likely use in later tutorials or your own projects.
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